DCS remote will not find TIU

My DCS remote will not find TIU. Any hints on trouble shooting this would be greatly appreciated. BTW, TIO and remote have been updated to the following software versions: Remote - 6.1; TIU - 6.0. Thanks for your help.


Original Post

Your remote and TIU should be on the same versions. TIU should be upgraded to match the remote. This is highly recommended by the DCS gurus. I don't know if that is your problem, I have not tried this, but the experts say strange things can happen when you mix versions.  

Engineer-Joe posted:

Why are they different? Upgrade the TIU to 6.1 also.

Is the TIU set for #1? Is it in the remote?

Have you tried to tether it? When you press read what do you see?


Yep good questions, lets take it a little further..... When you first apply power to the tiu there's a red  LED  on top that blinks.. Each  blink is the actual tiu number up to 5

Ex 1 blink means your tiu is TIU #1

  2 blinks means your tiu is tiu #2  and so on..

How many blinks on yours and has it   been added to the remote.

Next as  Joe  mentioned... Try it tethered with curly phone cable (if you have one)

jimentre posted:

Light on the TIU remains on. Also tethered unit - still not communicating. I believe the TIU is not functioning properly. Taking to a service center tomorrow. Thanks for all the recommendations.


Yep !Upon powering  up  the red  led is  suppose to remain on after blinking.....Did you get a chance to count the blinks?

Radio in the remote may have come loose. Happens alot.


TCA, METCA, LCCA, LRRC, MTHRRC, Atlas Golden Spike Club Charter Member, Bergen County Model RRC and NJ HiRailers Member.


If you haven't checked out the new NJ HiRailers website please do. Go to the "Photos" page to see galleries of our events and check the "What's New" page periodically to see what we've added.




Add Reply

Likes (1)
Alan Mancus
The DCS Forum is sponsored by

OGR Publishing, Inc. PO Box 218, Hilliard, OH 43026 330-757-3020