I've been having problems adding several PS2 engines to my DCS. These engines operated quite well for years, as do numerous others still. 

When I couldn't start my NYC Niagara and N&W J on the layout, I decided to move each engine to my test track, one at a time. Neither would start, so I deleted each engine and tried to re-add them. The message I get back, however, is that there is no engine to add. I've tethered the remote to the TIU, but get the same results. When I try the "Read"command, it finds TIU 1 but says that there are no engines on the test track. (I have version 6.10) I also tried to recover each of these engines but with no success. 

Any suggestions or tips would be most welcome.

Tom Mainwaring

Original Post

What are the item numbers for the locomotives? If they are early PS2 they probably have 5 volt boards, which can fail. Especially if they haven't been run recently. 

If other locomotives are adding fine to DCS then the issue is more than likely with the locomotives and not the TIU.

Santa Fe, All the Way

you might try making sure the battery's are good and hold a charge take battery out and put a light bulb or load and see how long the charge holds especially if you let your engine sit for long periods of time! I item number would help with your engines! try good batteries and try a conventional reset if that don't work and there 5 volt boards probably bad boards!

o gauge  trains ,music ,computer repair windows 7 and 10!

ASC Tech MTH school completed! 2019 !

It would help if you include the item # in your post.  Try the following:      

1.  Apply 18VAC to your test track thru your TIU.  check voltage with a DVM.

2.  Place a known good running engine on the track, reapply the 18 VAC.

3.  On your DCS remote hit the green Engine button.  Click S/U  (set up)

4.  Follow instructions that come up on the screen to add the engine.

5.  What do you get?

Bruce

I see it was asked, but let's try again.  How about the EXACT MTH product numbers for the problem locomotives?  You give us information, we give you help!

Many thanks for your suggestions. The engines in question are 20-3024-1 that has been upgraded to PS2 (with a BCR2) and 20-3047-1(with a BCR). I ran the Niagara as recently as 10 days ago; the N&W about a month ago before it developed the current problem.

I tried Bruce's suggestion. Track power is nearly identical to the transformer power. When I put a good engine on the test track and hit S/U, the response was "Engine in remote." 

Does a conventional reset mean pressing the horn button and then the bell button five times? I tried this numerous times but didn't get the two whistle blasts in response.

Tom Mainwaring

Good!  Now take the good engine off the test track and replace with one of your problem engines.

Repeat the process - if you get 'engine in  remote" -  the next thing you will see is its ID # and name in the remote.

Did you get this?  If so - press (3) start it up. Does it come alive?

Bruce

 

FWIW, I get this on occasion when I leave my test bench TIU powered up by mistake.  Even if I turn off power, if the USB connection is still on, the TIU fights with the other one.  

In response to Bruce's question, if I put a problem engine on the test track and follow the recommended procedure, the message I get back is "No engine to add."

I will follow Gunrunnerjohn's hint. I often leave the TIU powered up, so I turned it off tonight to see if I get different results tomorrow

Tom Mainwaring

I turned off power to the TIU overnight but when I powered up today this didn't solve the problem. The remote still won't recognize the two engines. 

I did discover one other problem engine today: a C&O Allegheny (20-3115-1). This engine ran as recently as last weekend, but today when I tried to start the engine on the track I got the message "Engine not on track." I tried it on the test track with the same result. But when I accidentally attached the power cord from the tender to the engine with power on the track, the engine started. The lights came on, sounds came on, steam, etc. But I couldn't turn off the engine except by turning off track power. When I tried to start the engine by conventional means, the "Engine not on track" message appeared. My suspicion is that these engines are OK but that something is wrong with the TIU or remote, but I don't know where to go from here.

Tom Mainwaring

Did you try tethering your remote to the TIU with a curly telephone cord? Your transceiver board in one or the other may have come loose. If that test works, you'll have to open them up and push down on them to reseat them. Then add a piece of foam to both their cover's to keep pressure on the boards so it don't happen again.

Dave Z

I'm starting to think your TIU may have experienced some signal loss for the DCS signal, did you try a different TIU channel?  If this is a Rev. L TIU, there is a recurring issue with the 74ACT244 chip losing gates and causing low DCS signal output.  What happens is marginal locomotives start failing to add first, as more gates in the chip fail, more locomotives fail to be recognized.  This has been discussed at some length here.

Some of the testing they can do, the signal strength is a little tricky, which is why we came up with the TIU signal tester.

However, many hobby shops don't have things like oscilloscopes and the like, so they might think testing the TIU with a locomotive on a test track is good enough, and it's really not.

Here's the whole thread on the TIU Tester project starting with Adrian's original idea for it.

Design of a $10-20 DCS-TIU Port Tester Tool?

Here's a quick demo I did with the TIU signal tester.

A shot of the actual PCB.

Dave, thanks for your suggestion about tethering the remote. Tried this but no results.

I did try using Fixed channel 2 on the test track and could then add the two engines. (I have the Rev L TIU.) So apparently Channel 1 is the culprit.  After I added the two engines, I could then run them via Channel 1. Many thanks for the suggestion to try a different channel. I haven't had time to look at the thread but will do so later tonight. Meanwhile it's a relief to have two engines back on track!

Tom Mainwaring

Guys like product numbers but when you say all of my trains no longer work on my layout, it really does point to the layout.  Make sure you have clean track, tight wire connections and did you do anything new?  Now that you have isolated a weak Fixed 1 but do have it working when engine loaded on Fix2, do a Track signal strength test with a single loco.  Use the same loop, once powered by F2 and the next time by F1.  If F1 is less chances are it is degraded and needs repair.  But worth making sure ALL DCS channels on.  And you can reset the TIU, followed by re adding engines one at a time.  G

MTH Authorized Service Center

Authorized ERR Dealer

Lionel Independent Repair Tech

Virginia Train Collectors Member

That seems to indicate that Channel #1 is the issue.  FWIW, that's not uncommon with the Rev. L units, I have replaced the ACT244 in about a dozen of them so far for the same issues.  I have one of mine that has a dead #1 channel that I have to get on the bench and fix as well.

After taking a look at the thread on chip issues with Rev L TIUs, my conclusion is that my technical skills wouldn't be up to this job. Who does repairs on TIUs with this problem? Does MTH do them? Any hobby shops in the Pittsburgh area? Other suggestions?

Tom Mainwaring

Add Reply

Likes (1)
Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×