Is MTH DCS Wi-Fi ready to run with Apple’s new operating system?  13.1.2

On September 24th, 2019 Apple will be updating their phones with a new operating system. The chatter at the Apple Store, Computer Talk Radio and Apple Forums is that some Apps may not work with the new OS 13.2

It is my understanding that Apple has told their App developers about this change six months ago, and the App developers have to make some changes to their Apps.

Has MTH Electric Trains updated their Wi-Fi App to work with the new operating system? (13.2)

I have turned off my auto update feature on my iPhone, so I do not have issues with the MTH DCS Wi-Fi.  I would like to update to OS 13.2 . I am also thinking about trading in my iPhone 7 Plus for the new iPhone Pro Eleven or basic Eleven.

1 v3.2.12 Build 33 Auto Off

If you have any knowledge on these issues, I would like to hear from you.

Take care: Gary

Attachments

Photos (3)
Original Post

Hi Marty E..... Got it...  but has MTH updated their App to run with iOS 13?

Do you run MTH DCS Wi-Fi with an Apple device?  I hate to go first. I am in a holding pattern in the rail yard, just north of Detroit. 

4 Got it

Thanks Gary

Attachments

Photos (1)
MartyE posted:

I can find out tomorrow and report back. I doubt the app would even launch if incompatible. 

Hi Marty E

Cool: I will do the same. I am going to try to get to my local Apple Store.  The local TV channels were showing large crowds because of the iPhone Eleven went on sale today.  Or just call Apple Support and on Monday I will check in with MTH support.

Sometimes all these iPhone computer nerds, are just saying the, "Sky is falling"........ & it is not......

Gary

I traded in my iPhone 7 Plus for new iPhone 11 Pro and now running iOS 13.2.1 •  The Apple Store did the data transfer. I have reported several issues to MTH online support and the MTH service line.  This part of the company is located in St. Joseph, Michigan.

I provided several screenshots explaining the issues. I have been assigned a technician and we are working on a solution. As of today’s date these issues have not been resolved.

Gary

Danr posted:

Now running iOS beta 13.2 on an iPhone X with no problems.

Gary, would you, please, let us know what kind of problem(s) you encountered, I would like to see if I can duplicate them.

Hi Dan R:

Below are two screenshots that go over the issues. you are on a iPhone X and I am on a iPhone 11 Pro. You can try to duplicate but it is the old saying "Apples & Oranges" .  I was told by Apple that a communication was send to all the Apple App Developers about six months ago, going over the changes that they may have to do to have their Apps operate on the iPhone 11's.  

MTH Trains is working on this issue but no one in their office has the new Apple 11.  MTH suggested that I have my adult son come over and test my layout with his Android Phone. He has MTH DCS WiFi on his phone and if my layout works, this means my WiFi TIU is OK and there is an issue with the iPhone 11's.

These iPhones 11's are only about 3 weeks old and iOS 13.2.1 is only about 5 days old. MTH also suggested that I restart the MTH App, I tried to do this but I got a warning that I would lose all the information on the App.  There is a work around for this but I am going to check with my adult son first.

1 Connection FAiled

 

3 Whistle Cord

Thanks for asking and I hope this helps...

Gary

Attachments

Photos (2)

Hi, Gary and all.  You mentioned that you were running IOS 13.2.1 but I believe you are running 13.1.2, which is the current, public IOS release.  Current versions of all should be:

IOS 13.1.2 (public)

IOS 13.2 (beta)

DCS app 3.2.1

WIFI 1.1

I am running IOS 13.2 beta on an iPhone X.  My iPad has IOS 13.1.2.

I was able to duplicate the problem with the whistle/horn cord but only once.  On a phone when you pull the cord down, it is extremely close to “80” on the speedometer.  One time when I pulled the cord down I it “80” which locked the cord down and blew the whistle continuously.  I had to close the app to get it to let go and turn off power to stop the locomotive whistle.  When I tried again, I could not duplicate the problem but, it does exist.  My guess is that the touch zone for speed control and whistle control are too close together.  Depending upon how fat your fingers are it is possible to hit both at the same time and confuse the app.

I was unable to duplicate the problem of moving locomotives between the active and inactive list.  Items were easily moved between active and inactive, this included both MTH and Lionel locomotives.  I did notice on the active/inactive screen for the iPhone after clicking edit, my finger had to be exactly on the 3 horizontal bars to the right of the locomotive name otherwise, nothing would move.  On the iPad you had to be a little bit to the left of the 3 bars to move an item.  I also noticed that you need to drag the item all the way into the active or inactive area; if not it just bounced back from where it came.

Non sequitur to the issues you raised, while running these tests I discovered one Lionel Legacy locomotive that had no horn (the icon is grayed out).  I deleted it and added it several times but it stubbornly refuses to have a horn.  I know it is there and works just fine with the CAB2.

I do not know if the helps anyone in any way.

Dan

After playing with the app for a while i managed to get the whistle/horn button to stay in the down position.  At that point the app locked up so, I had to force it closed.  When I brought it back up, all of the locomotives were in the inactive group.  I tried to move a loco to active but got a message that it could not communicate with the loco.  I rebooted the wifi and start over.  All of the locos were still in inactive but I could get to them and move them to active.  Everything seems to be working correctly - not sure why.  In the meantime the Lionel locomotives are working correctly.  I noticed that the horn icon which is yellow for most locomotives, it grayish white (silver?) for quillable whistles - I couldn't find that tidbit in the instructions, but it works.

Dan

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×