Review of the New Lionchief Promontory Summit Anniversary Set.  Pretty Nice, but they have some issues that look like will be a problem for all sets.

1.  Cannot get the smoke to work on the 119 engine, not sure why but I tried 2 sets and same issue.

2.  The sounds on the 119 are too low and even turned all the way up you can't hear the chuffs or announcements when actually running because the Generals are kind of noisy to begin with, just by their nature.  You can hear them at standstill no problem, but when side by side you can hear a huge difference in volume.  The Jupiter sounds are very loud.  Not sure if the soundest was recorded too low or what the issue is, but they should be the same as far as the mechanicanics/electronics.  Maybe Lionel can chime in on these issues.

I know it is just a Lionchief set but it is 500.00, so not just a few bucks.

 

https://youtu.be/Anfg8tLCWxA

 

 

 

Sean

Original Post
SandJam posted:

Review of the New Lionchief Promontory Summit Anniversary Set.  Pretty Nice, but they have some issues that look like will be a problem for all sets.

1.  Cannot get the smoke to work on the 119 engine, not sure why but I tried 2 sets and same issue.

2.  The sounds on the 119 are too low and even turned all the way up you can't hear the chuffs or announcements when actually running because the Generals are kind of noisy to begin with, just by their nature.  You can hear them at standstill no problem, but when side by side you can hear a huge difference in volume.  The Jupiter sounds are very loud.  Not sure if the soundest was recorded too low or what the issue is, but they should be the same as far as the mechanicanics/electronics.  Maybe Lionel can chime in on these issues.

I know it is just a Lionchief set but it is 500.00, so not just a few bucks.

 

https://youtu.be/Anfg8tLCWxA

 

 

 

This is not a "review" but a complaint.

Contact Lionel and come back again.

 

 

RT   

rthomps posted:
SandJam posted:

Review of the New Lionchief Promontory Summit Anniversary Set.  Pretty Nice, but they have some issues that look like will be a problem for all sets.

1.  Cannot get the smoke to work on the 119 engine, not sure why but I tried 2 sets and same issue.

2.  The sounds on the 119 are too low and even turned all the way up you can't hear the chuffs or announcements when actually running because the Generals are kind of noisy to begin with, just by their nature.  You can hear them at standstill no problem, but when side by side you can hear a huge difference in volume.  The Jupiter sounds are very loud.  Not sure if the soundest was recorded too low or what the issue is, but they should be the same as far as the mechanicanics/electronics.  Maybe Lionel can chime in on these issues.

I know it is just a Lionchief set but it is 500.00, so not just a few bucks.

 

https://youtu.be/Anfg8tLCWxA

 

 

 

This is not a "review" but a complaint.

Contact Lionel and come back again.

The link is the review. 

It is not a complaint.  It just stating the issues.  Lionel takes 2-3 weeks every time I e-mail them to reply.  I just got a reply to a question I sent on Nov 2nd on Saturday. 

Also when something is just released none of the operators know anything about it.  It is extremely frustrating as all they want you to do is send it back.

Sometimes issue get more bite on the forum if Dave sees them.

I usually try to figure it out myself if I can as it is quicker.

I noticed the guys on the forum like Marty get immediate responses, but guys like me that don't have a direct relationship with the guys at Lionel have a much harder time.

So I have sent an e-mail, but there is nothing wrong with stating issues with a 500.00 set

Your responses are not helpful in any way.

Sean

Video review itself called out the positives as well.  I don't think Sean is doing any wrong by calling out the issues that were duplicated over the 2 sets he tried from his LHS. 

2 sets exhibiting identical problems/characteristics would indicate it's not just "one snuck through manufacturing".  Does it mean every single one is like that?  No one can say unless many others all have the same issues. 

-Dave

Dave45681 posted:

Video review itself called out the positives as well.  I don't think Sean is doing any wrong by calling out the issues that were duplicated over the 2 sets he tried from his LHS. 

2 sets exhibiting identical problems/characteristics would indicate it's not just "one snuck through manufacturing".  Does it mean every single one is like that?  No one can say unless many others all have the same issues. 

-Dave

Exactly, which is why I posted it to see if anyone else has same issues.  That’s one of the positive aspects of the forum to get information.

Sean

Sean, thanks for the review video and noting in your post a couple of concerns.

rthomps posted:  

This is not a "review" but a complaint.

Contact Lionel and come back again.

Did you even watch the video?  What would be needed to turn the video into a "review" in your opinion?

Carl

SandJam posted:

The link is the review. 

It is not a complaint.  It just stating the issues.  Lionel takes 2-3 weeks every time I e-mail them to reply.  I just got a reply to a question I sent on Nov 2nd on Saturday. 

Also when something is just released none of the operators know anything about it.  It is extremely frustrating as all they want you to do is send it back.

Sometimes issue get more bite on the forum if Dave sees them.

I usually try to figure it out myself if I can as it is quicker.

I noticed the guys on the forum like Marty get immediate responses, but guys like me that don't have a direct relationship with the guys at Lionel have a much harder time.

So I have sent an e-mail, but there is nothing wrong with stating issues with a 500.00 set

Your responses are not helpful in any way.

While my advice wasn't the fix, it is a good place to start.  If nothing else it makes them aware of a potential issue.  Also checking here on the forum is always a good option.  I just wondered if Sean had contacted Lionel yet and if they gave him a response.  I enjoy Sean's reviews.  They are usually some of the best on-line.

Immediate? I, like most, go through the call center. If I post something here I usually add the @Dave Olson tag that gets his attention.  That usually is like putting the Bat signal up.

 

Marty

 

Below the Signature...

" Number One, make it "O"!"

 

MartyE posted:
SandJam posted:

The link is the review. 

It is not a complaint.  It just stating the issues.  Lionel takes 2-3 weeks every time I e-mail them to reply.  I just got a reply to a question I sent on Nov 2nd on Saturday. 

Also when something is just released none of the operators know anything about it.  It is extremely frustrating as all they want you to do is send it back.

Sometimes issue get more bite on the forum if Dave sees them.

I usually try to figure it out myself if I can as it is quicker.

I noticed the guys on the forum like Marty get immediate responses, but guys like me that don't have a direct relationship with the guys at Lionel have a much harder time.

So I have sent an e-mail, but there is nothing wrong with stating issues with a 500.00 set

Your responses are not helpful in any way.

While my advice wasn't the fix, it is a good place to start.  If nothing else it makes them aware of a potential issue.  Also checking here on the forum is always a good option.  I just wondered if Sean had contacted Lionel yet and if they gave him a response.

Immediate? I, like most, go through the call center. If I post something here I usually add the @Dave Olson tag that gets his attention.  That usually is like putting the Bat signal up.

 

Not yet. The set just came to my hobby shop Friday and I didn’t get to open it until late Sat night, so Lionel is closed until Monday.  I will if I can’t figure it out.  Just thought I’d see if anyone else had same issues.

Sean

SandJam posted: 

Not yet. The set just came to my hobby shop Friday and I didn’t get to open it until late Sat night, so Lionel is closed until Monday.  I will if I can’t figure it out.  Just thought I’d see if anyone else had same issues.

I'd call and talk to a human.  While they might have you try all the stuff you already did, maybe they could get someone else on the line.  It's worth a shot.  Sorry to hear you are having issue.  Hopefully the Bat signal helps.

Marty

 

Below the Signature...

" Number One, make it "O"!"

 

Personally I think the issue of sound is something than can be attributed to the fact that some people will use this as a Promontory Recreation piece rather than individually running the engines by their lonesome (at least to me). The Lionel Vision Line Baldwin Centipede comes to mind in regards to @SandJam's "issue" with one engine being louder than the other. While I do not own one myself (nor will I probably ever), I believe @ericstrains.com explained it best. One unit has a louder sound, while the other is quieter and more echo-y to contrast to one unit providing basically every bit of noise. Granted, the Promontory Set sounds a bit hard to control with a Lionchief remote compared to a Legacy but I think that is the case. I think the same can be applied with a Legacy remote, but I dont think Lionel ever made it clear if this set was supposed to be Lionchief, Lionchief Plus or Lionchief Plus 2.0.

As for the smoke, thats a loss for me.

Here is Eric's Video on the centipede.

The tracks ahead are rough, but I can still see a bright future for the hobby of model railroading. We've just got to show our youth that the hobby of railroading is just as fun as any video game.

SandJam posted:

Review of the New Lionchief Promontory Summit Anniversary Set.  Pretty Nice, but they have some issues that look like will be a problem for all sets.

1.  Cannot get the smoke to work on the 119 engine, not sure why but I tried 2 sets and same issue.

2.  The sounds on the 119 are too low and even turned all the way up you can't hear the chuffs or announcements when actually running because the Generals are kind of noisy to begin with, just by their nature.  You can hear them at standstill no problem, but when side by side you can hear a huge difference in volume.  The Jupiter sounds are very loud.  Not sure if the soundest was recorded too low or what the issue is, but they should be the same as far as the mechanicanics/electronics.  Maybe Lionel can chime in on these issues.

I know it is just a Lionchief set but it is 500.00, so not just a few bucks.

 

https://youtu.be/Anfg8tLCWxA

 

 

 

MEA CULPA, Sean! 

Truthfully, I did not see the link or understand that your "review" was on the YouTube link.  I was in a hurry this morning ... and, I simply MISSED IT.  I guess sometimes I need things pointed out.  

Thanks for the information -- and for posting video.  I have that set coming soon.

Apologies.  

 

 

RT   

Pingman posted:

Sean, thanks for the review video and noting in your post a couple of concerns.

rthomps posted:  

This is not a "review" but a complaint.

Contact Lionel and come back again.

Did you even watch the video?  What would be needed to turn the video into a "review" in your opinion?

I did not see the video.  See my apology above ....

 

 

RT   

TheRWBYRailfan posted:

Personally I think the issue of sound is something than can be attributed to the fact that some people will use this as a Promontory Recreation piece rather than individually running the engines by their lonesome (at least to me). The Lionel Vision Line Baldwin Centipede comes to mind in regards to @SandJam's "issue" with one engine being louder than the other. While I do not own one myself (nor will I probably ever), I believe @ericstrains.com explained it best. One unit has a louder sound, while the other is quieter and more echo-y to contrast to one unit providing basically every bit of noise. Granted, the Promontory Set sounds a bit hard to control with a Lionchief remote compared to a Legacy but I think that is the case. I think the same can be applied with a Legacy remote, but I dont think Lionel ever made it clear if this set was supposed to be Lionchief, Lionchief Plus or Lionchief Plus 2.0.

As for the smoke, thats a loss for me.

Here is Eric's Video on the centipede.

That makes sense for 2 engines that are lashed as one.  But these are not linked together and are separate engines, so I don't think that theory holds true.  Plus it is all sounds, not just chuff, including the announcements while running which are hard to hear even at full volume on the 119.

Sean

rthomps posted:
SandJam posted:

Review of the New Lionchief Promontory Summit Anniversary Set.  Pretty Nice, but they have some issues that look like will be a problem for all sets.

1.  Cannot get the smoke to work on the 119 engine, not sure why but I tried 2 sets and same issue.

2.  The sounds on the 119 are too low and even turned all the way up you can't hear the chuffs or announcements when actually running because the Generals are kind of noisy to begin with, just by their nature.  You can hear them at standstill no problem, but when side by side you can hear a huge difference in volume.  The Jupiter sounds are very loud.  Not sure if the soundest was recorded too low or what the issue is, but they should be the same as far as the mechanicanics/electronics.  Maybe Lionel can chime in on these issues.

I know it is just a Lionchief set but it is 500.00, so not just a few bucks.

 

https://youtu.be/Anfg8tLCWxA

 

 

 

MEA CULPA, Sean! 

Truthfully, I did not see the link or understand that your "review" was on the YouTube link.  I was in a hurry this morning ... and, I simply MISSED IT.  I guess sometimes I need things pointed out.  

Thanks for the information -- and for posting video.  I have that set coming soon.

Apologies.  

No worries, we are all human

Sean

Update - Went back to Nicholas Smith today.  They opened another set, we tried to get the 119 to smoke, no go.

We ran it for a good 10 min, ZW-L full track power.  We tried smoke switch in both positions.   We flipped the switch while it was running and you could see smoke unit was drawing power because engine would slow a bit and amps on ZW-L went up.

Our guess is the factory forgot to add the batting (just a guess).  They tried to call Lionel but we just were on hold for 20 min.

They then contacted their rep and the rep did not know about anything happening with the sets so they are investigating.

So 3 sets in a row and no smoke.  Sounds on the 3rd set were also way too low at full volume.

My only issue if they ask to send it in, is that you have to break details to get these Generals apart, they are not easy to get apart as you think they would be, so probably would get them back all chewed up.  

Will wait to see what Lionel will do.

 

 

Sean

Great review, just like the rest. On the note of the smoke unit, have you checked if the unit was placed properly in the engine. What might have happened is that the hole for the stack and unit are not matching up. Also, you mentioned that the whistle sounded like a horn than a whistle. The whistle that Lionel put in them is correct, for the quality, but I agree that maybe Lionel should have put a better sound in it. Thanks again and very nice scenery.  

I was shown a picture of the smoke element in the unit in question.  There is about 1/4" at most of resistor that can vaporize the fluid.  The rest of the resistor is insulated to keep from shorting.  My guess is the reason why it doesn't smoke well.  

Marty

 

Below the Signature...

" Number One, make it "O"!"

 

MartyE posted:

I was shown a picture of the smoke element in the unit in question.  There is about 1/4" at most of resistor that can vaporize the fluid.  The rest of the resistor is insulated to keep from shorting.  My guess is the reason why it doesn't smoke well.  

The problem is it does not smoke at ALL.    I went to Nicholas Smith and we tried 3 different ones.  No smoke at all out of the 119.

 

Not sure how to fix since the bowl is so small and tight without shorting it against the metal bowl.

Either way tearing these apart is difficult and you have to break details.

So I would say if you buy the set, resign to the fact the 119 probably won't smoke.  Or send it back to Lionel and probably expect a damaged shell or details when you get it back.

Also the parts diagram shows this have a sleeve over resister, no wadding (probably no room for it).

Not sure why the Jupiter is fine but the 119 isn't.  Maybe different assembly lines.

By the way Lionel is silent, dealer said they would contact me when they got an answer.

Attached is the pic from Jim Sandman who took one apart to troubleshoot.

 

  119 Smk

 

Sean

Attachments

Photos (1)
SandJam posted:
MartyE posted:

I was shown a picture of the smoke element in the unit in question.  There is about 1/4" at most of resistor that can vaporize the fluid.  The rest of the resistor is insulated to keep from shorting.  My guess is the reason why it doesn't smoke well.  

The problem is it does not smoke at ALL.    I went to Nicholas Smith and we tried 3 different ones.  No smoke at all out of the 119.

 

Not sure how to fix since the bowl is so small and tight without shorting it against the metal bowl.

Either way tearing these apart is difficult and you have to break details.

So I would say if you buy the set, resign to the fact the 119 probably won't smoke.  Or send it back to Lionel and probably expect a damaged shell or details when you get it back.

Also the parts diagram shows this have a sleeve over resister, no wadding (probably no room for it).

Not sure why the Jupiter is fine but the 119 isn't.  Maybe different assembly lines.

By the way Lionel is silent, dealer said they would contact me when they got an answer.

Attached is the pic from Jim Sandman who took one apart to troubleshoot.

 

  119 Smk

 

I agree with you on that Lionel has been silent. I have tried all of last week on trying to call them about a custom run and I would be on hold for about 20 minutes, while listening to nascar announcements, and then their system would boot me to voicemail. Lionel If you see this, what in the world is going on?  

MartyE posted:

When you are prompted to leave your number, do so. They called me back to register my concern on the Js stripe. I believe it was Arron who returnEd my call. 

Thanks, I tried but they still didn’t call me back. I’ll try again tomorrow and marry Christmas!!!

shawn posted:

If these sets have any switches for smoke on off. Or, chuff on off. I would check that the switches are correct from the manual by manual testing. I had a starter set blue comet. The switches were backward from the manual. 

We tried all that. This is not the first time around the block for Nicholas Smith, lol.  They know all the pitfalls.

Sean

Robprince posted:

I picked one up this week and it’s working perfectly ....smoke and sounds are functioning properly.  It’s a very nice set 

Glad to know some out there work! 

Nicholas Smith has been jammed so I will wait until after Christmas and we will try some other ones and see if I can find a working one or I will just return it.  Lionel has not gotten back to them either.

They are handling it for me.  I got tired of being on hold the 2 times I called.  

Sean

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×